Please ensure Javascript is enabled for purposes of website accessibility
Powered by Zoomin Software. For more details please contactZoomin

Unified Supply Chain Process Model Manager

Data grid

  • Last UpdatedAug 14, 2026
  • 10 minute read

The Data Grid shows all Data Sets configured in the Data Sets List in a single Measurement Grid. The individual Data Sets are shown as columns across the top of the Data Grid. For each of the Output streams configured in the Model Definition (Outputs) the properties associated with the stream are shown as rows in the Data Grid.

These properties may belong to the Material Type (Material types) associated with that stream, or may have been added independently to the stream in the Outputs list (Outputs).

The Data associated with each set can be entered into the Data Grid. Where the Data Set is defined as Manual the property values are entered directly in the Data Grid for the relevant Data Set. Where the Data Set is defined as Calculated the crude with which the Data Set is associated is shown at the top of the Data Set's column.

Each cell can have up to three numbers:

  1. The main value is bold if it’s a user-entered value, otherwise it’s been calculated by running the data set. If the value is grey, then it matches the base data set (the blue column).

  2. The bottom right value is the original value from the calculation if you have entered your own value (this will only show if the main value is bold).

  3. The top right value is present when you also have a regressed B+D model. It’s the value predicted by the model for that output based on the inputs in that column. If the value is grey then the regression is out of date (and the B+D model grid will also be stripy).

Filter the Data Grid

Streams and Properties in the Data Grid can be filtered for display by typing their information in the Filter menu

The Filter menu allows streams and properties in the Data Grid to be quickly found. Type the name of the item in the Filter menu, and only the relevant rows will be shown in the grid.

The Filter menu allows specific rows and columns to be quickly screened and Bases to be hidden

Select All from the Filter menu to show all the Data Grid rows will be shown.

To show or hide specific Bases select the check box or deselect the Base's name in the Filter menu.

Enter Data in the Data Grid

There are several ways to enter data into the Data Grid:

  • calculte from Tunesets

  • directly type values into the grid

  • copy and paste values from other software applications such as Microsoft Excel.

Calculate from Tunesets

When Tunesets have been configured to set up multiple process unit configurations, the Tunesets are associated with Data Sets in the Data Grid Column Headers

Data Set values can be calculated from the set of parameters defined in a Tuneset (Process Unit Model dialog). Select the required Tuneset from the list of available Tunesets in the Tuneset Column header menu; the Tuneset must have been previously configured using the Process Unit Model dialog in the Topology.

Cut, Copy and Paste Data in the Grid

You can transfer data from selected grid cells to external programs by using the cutting, copying and pasting functionality. This can be accessed in a number of ways:

  • Use Cut, Copy, Copy Special and Paste from the Edit menu.

  • Use the Ctrl + X, Ctrl + C, Ctrl + Shift + C and Ctrl + V keyboard shortcuts.

  • Press the , , and buttons for cut, copy, copy special and paste respectively.

Copying a selected region of the grid will place a copy of the information associated with those cells onto the clipboard, from where it can be pasted over cells in the same grid, into other grids, or into an external program (such as Microsoft® Excel® spreadsheet software) for further analysis.

Conversely, data can be pasted into the Process Model Manager Reference Manual grids from external programs, or from other grids. Cutting data copies it to the clipboard, before permanently removing it from the grid.

Select cells

Any rectangular subsection of the grid can be selected by clicking on a cell, and dragging to the opposite corner. For a selected area of cells you can:

  • Delete the contents by pressing the Delete key, or by selecting Cut from the Edit menu.

  • Copy or cut the contents ("Cut, Copy and Paste Data in the Grid " on the previous page).

Non-contiguous selection

You can select a range of non-contiguous cells in the Data Grid by holding down the Ctrl key while making your selection; the selected cells are displayed shaded in blue. This is similar behaviour to that of Microsoft® Excel® spreadsheet software.

You cannot cut, copy, paste or drag and drop non-contiguous selection areas. This is similar behaviour to that exhibited by Microsoft® Excel® spreadsheet software.

Drag and drop

The Data Grid permits you to move or copy a selection by dragging and dropping it.

  • To move a selection: Select a range of cells in the Data Grid, and position the cursor along the bounding box until the drag and drop cursor appears. Then simply drag the selection to the desired location and drop it. The selected range of cells will be moved to the new location.

  • To copy a selection: Select a range of cells in the Data Grid, and position the cursor along the bounding box until the drag and drop cursor appears. While holding down the Ctrl key, drag the selection to the desired location and drop it. The selected range of cells will be copied to the new location.

Select a row or a column

To select a complete row or column, move the mouse pointer to the top of a column, or to the left of a row. The cursor will change to an arrow cursor . Clicking will select the whole row. To select multiple rows or columns, click and drag from one column to another column.

Select All

To select the whole grid you can:

  • Click in the top left of the grid.

  • Use the Ctrl + A keyboard shortcut.

  • Choose Select All from the Edit menu.

Clear rows and columns

You can clear a row or a column by selecting the row or column and pressing the Delete key. The selected row or column will be cleared accordingly.

Context Menu

Several options are available in the Context Menu for working with the Data Grid:

  • Calculate Selected Data Set(s): calculates the Data Sets properties values for the selected Data Set columns.

  • Calculate All Data Sets: recalculates the property value for every Data Set.

  • Insert Row With New Calculated Input...: adds a new row to the Data Grid, allows a User Calculation to be entered for its calculations and allows the calculation to be associated with an Input property.

  • Insert Row With New Calculated Output...: adds a new row to the Data Grid, allows a User Calculation to be entered for its calculation and allows the calculation to be associated with an Output property.

  • Edit Selected Calculation: allows the underlying User Calculation used to derive the row's values to be edited.

  • Create Automatic NLFE Override for Row: creates an override for the specific gravity of a non-liquid stream, using the SRF and NLFE values defined in the Details page (Override specific gravity for non-liquid streams). This menu entry is not visible unless you right click on the specific gravity row of a non-liquid stream, without any override already defined.

  • Create Offset/Override for Row...: allows a custom User Calculation to be defined to offset or to completely override the row's values (Create offsets or overrides).

  • Enable Offset/Override for Row...: enables the offset or the override defined on the current row.

  • Clear Offset/Override for Row...: deletes the offset or the override defined on the current row.

  • Set as Base Data Set: makes the current selected Data Set the Base Data Set for regression. This menu entry is not visible if a single Data Set is defined.

  • Cut: cuts the selected values to the clipboard.

  • Copy: copies the selected values to the clipboard.

  • Paste: pastes the contents of the clipboard to the Data Grid.

  • Clear Contents: removes the contents of the selected cells.

  • Reset Width and Heights: returns the column widths and row heights to their default values.

Define Calculations from the Data Grid

The Insert Row With New Calculated Input... and Insert Row With New Calculated Output...options on the Data Grid context menu allow new input and output properties based on User Calculations to be added to the case.

When adding a new property from the context menu you must define the User Calculation used to determine the value of the property. Once you click OK, you must then choose the stream to associate the property with. When creating an input property this must be an Input stream; when creating an output property this must be an Output stream.

Assigning a stream and a default tag to a calculation

Create Offsets or Overrides

Offsets or Overrides can be applied to Data Grid rows to adjust or completely recalculate values

When you choose to offset or override the values of a row, the Offset or Override Formula dialog window opens. The Formula field is where you define the formula describing the offset or override.

To define the formula you can use the variables listed in the Variables grid.Use the , and buttons to add, edit and delete variables. The predefined OriginalValue variable corresponds to the values in the row before the offset or override is applied.

Finally, in the Comment field you can write a brief explanation about the offset or override you are applying.

Override specific gravity for non-liquid streams

You can automatically create an override for the specific gravity of a non-liquid stream using the following formula:

Specific gravity = NLFE/SRF/StreamCalorificValue

where:

  • NLFE is the Non-Liquid Fuel Equivalent calorific value, defined in the Details page.

  • SRF is the Standard Refinery Fuel calorific value, also defined in the Details page.

  • StreamCalorificValue is the calorific value for the stream. It must be defined in the data grid using TSRF/T as unit of measure.

To add the override, follow these steps:

  1. Right click on the specific gravity row for the stream.

  2. Choose Create Automatic NLFE Override for Row from the menu.

    The override is created, and you can then view and modify it like any other override, by right clicking on the row and choosing Edit Offset/Override for Row from the menu.

    Note that another override is created for the volume-based yield of the stream, to take into account the new specific gravity, using the following formula:

    Gas yield = OriginalValue * OriginalSPG / StreamSPG

    where:

    • OriginalValue is the yield before the override.

    • OriginalSPG is the specific gravity before the override.

    • StreamSPG is the specific gravity after the override.

    The automatic specific gravity override. Note the override icon on the Gas Yield (vol) row as well.

    Undo and Redo capability

    If you make a mistake in working up a crude in a Document, you can roll back your work until you reach a previously correct state by selecting Undo from the Edit menu or by pressing the Undo button on the Toolbar.

    If you would like to repeat your previous action, you can do so by selecting Redo from the Edit menu or by pressing the Redo button on the Toolbar.

    Data Grid Diagnostics

    Feedback in the Data Grid shows if they are any problems with the fitted data:

    • - there was a problem fitting the highlighted Data Set. Check the entered values.

    • - the highlighted Data Set has been changed since the last regression and requires recalculation.