Web thin client project settings
- Last UpdatedOct 29, 2026
- 2 minute read
Web thin client projects require specific project settings, tag database settings, and screen configurations.
To configure web thin client project settings:
-
On the Project tab of the ribbon, in the Web group, click Thin Clients to open the Project Settings > Web dialog.

-
In the Data Server IP Address field, enter the IP address of your PC (as viewed from the network), such as 192.168.1.100.
You can get IP address from the Network Settings in the Control Panel, or putting the function GetComputerIP() in a Rectangle object on a screen and running the project.
-
Check the Auto Screen Scaling, Enable File Compression, and Enable Tooltips checkboxes.
-
Click on the Firewall button. If necessary, uncheck the Enable checkbox. Click OK.
-
Click on the Advanced Button. If necessary, uncheck the Web Tunneling Gateway Enabled checkbox. Click OK.

-
-
On the Home tab, click Runtime Tasks to open the Runtime Tasks dialog box and set the TCP/IP Server task Startup to Automatic. (Highlight the task, click the Startup button, choose Automatic, then click OK.) Then click OK to exit the dialog.
To configure the tags database:
-
In the Development Environment, select the Global tab of the Project Explorer. Open the Project Tags folder.
-
Be sure the project tags are properly set to either Server or Local. If the tags are to be exposed to the Web Client, then set them to Server, otherwise set to Local.
To develop your screens and create HTML screens:
-
Develop your project screen. Depending on your Thin Client screen size, you may want to develop a separate set of screens with a different resolution. Auto Screen scaling is supported (enabled in a prior step), but auto screen scaling naturally has limitations.
-
Save and close all project screens.
-
Be sure you have defined a Startup Screen (Viewer on the Project tab of the ribbon).
-
You can save individual screens as HTML by selecting the Save as HTML or Save Screen Group as HTML options in the File menu, or save all Screens and Screen Groups as HTML by selecting the Save All as HTML option.
-
If you are just updating a Screen, and especially when you make any configuration changes to the Web settings, you should run the Verify Project tool (that is, on the Home tab of the ribbon, in the Tools group, click Verify).
-
The HTML (web) pages will be stored in the Web sub-folder of your project folder.