Please ensure Javascript is enabled for purposes of website accessibility
Powered by Zoomin Software. For more details please contactZoomin

AVEVA™ InTouch HMI

Utiliser la grille d’édition

  • Last UpdatedSep 24, 2024
  • 4 minute read

Le Gestionnaire de recettes dispose d'un ensemble de commandes d'édition pour ajouter, modifier ou supprimer des données dans les modèles. En général, pour modifier les données souhaitées, il faut les sélectionner puis choisir une action. Le tableau suivant décrit les fonctionnalités communes des modèles de recettes permettant de saisir ou sélectionner leurs données.

Fonctionnalité

Description

Zone de saisie

Zone de texte utilisée pour entrer des données dans la cellule sélectionnée du modèle. Lorsqu'une cellule est sélectionnée, son contenu s'affiche dans la zone de saisie, dans la partie supérieure de la boîte de dialogue Gestionnaire de recettes.

Sélection de toutes les cellules

Cliquez sur la cellule à l’angle supérieur gauche du modèle pour sélectionner toutes les cellules.

Select All Cells feature

Sélection de toutes les lignes

Cliquez sur un nom de ligne dans le modèle, pour sélectionner toutes les cellules de cette rangée.

Sélection de toutes les colonnes

Cliquez sur l’en-tête d’une colonne dans le modèle pour sélectionner toutes les cellules de cette colonne.

Redim. automatique de toutes les colonnes

Double-cliquez sur un modèle pour aligner automatiquement toutes les colonnes sur la largeur de l'entrée la plus longue.

Redim. automatique d'une colonne

Double-cliquez sur l'en-tête d'une colonne pour l'aligner automatiquement sur la largeur de son entrée la plus longue.

Remarque : la colonne Type d’élément de la Définition du modèle ne peut pas être redimensionnée.

Lorsque vous modifiez un modèle, vous pouvez :

  • Effacer les données d'une plage de cellules.

  • Copier les données d'une plage de cellules vers une plage de cellules adjacentes.

  • Insérer une ligne dans la Définition du modèle.

  • insérer une colonne dans un modèle.

  • Effacer une ligne de la Définition du modèle.

  • Supprimer une colonne du modèle.

Effacer les données d’une plage de cellules

  1. Sélectionnez une plage de cellules dans le modèle.

    Clear data from cells

  2. Dans le menu Edition, cliquez sur Supprimer. Un message vous demande de confirmer la suppression de la plage de cellules sélectionnée.

  3. Cliquez sur Oui. Le modèle efface les données de la plage de cellules sélectionnée.

Pour copier une plage de cellules vers une plage adjacente

  1. Sélectionnez la cellule ou la plage de cellules à recopier.

  2. Sélectionnez la plage de cellules adjacente où les données seront copiées.

    Copy cells to adjacent selected range

    Les plages sélectionnée doivent être de même taille et peuvent se situer au-dessus, en dessous, à droite ou à gauche de la plage d'origine.

  3. Dans le menu Edition, sélectionnez la commande de remplissage appropriée. Les données sont recopiées dans la plage de cellules sélectionnée.

    Remarque : si la nouvelle colonne de destination des données n’est pas assez grande pour contenir l’entrée la plus grande, double-cliquez sur son en-tête pour modifier sa largeur.

    Insérer une ligne dans la Définition du modèle

    1. Sélectionnez le modèle Définition du modèle.

    2. Cliquez sur l’Élément numéroté pour sélectionner la ligne de Définition du modèle au-dessus de laquelle la nouvelle ligne est insérée.

      Vous ne pouvez pas insérer directement des lignes dans la Définition des recettes ni dans la Définition des unités. Au lieu de cela, toutes les modifications apportées à la Définition du modèle sont automatiquement reflétées par la Définition des recettes et la Définition des unités.

    3. Dans le menu Édition, cliquez sur Insérer. Une nouvelle ligne est insérée juste au-dessus de la ligne sélectionnée, et les lignes suivantes sont renumérotées automatiquement.

      Insert row in Template definition

      Remarque : si les valeurs maximum paramétrées dans les Préférences du gestionnaire de recettes sont atteintes, la commande Insérer reste inactive. Vous devez alors augmenter les valeurs en question pour pouvoir ajouter des éléments, des unités ou des recettes dans vos modèles.
      Lorsque vous modifiez vos Préférences, les modifications s'appliquent à tous les fichiers modèles de recettes existants.

      Insérer une colonne

      1. Cliquez sur le numéro d’Unité ou de Recette : la colonne sélectionnée se retrouvera à droite de l’insertion.

        Vous pouvez insérer des colonnes dans la Définition des recettes ou dans la Définition des unités.

      2. Dans le menu Édition, cliquez sur Insérer. Une nouvelle colonne est insérée sur la gauche de la colonne sélectionnée.

        Insert row in Unit definition

        Dans cet exemple, les données Mixer2 sont déplacées sous la colonne Unité 3 et une nouvelle colonne est insérée sous Unité 2.

        Supprimer une colonne

        1. Cliquez sur les Numéros d’unité ou Numéros de recette pour sélectionner la colonne à supprimer.

          Vous pouvez effacer des colonnes de la Définition des recettes ou de la Définition des unités.

        2. Dans le menu Édition, cliquez sur Supprimer. Un message vous demande de confirmer la suppression.

        3. Cliquez sur Oui. La colonne est supprimée du modèle, et les colonnes restantes sont renumérotées.

          Supprimer la ligne

          1. Sélectionnez la modèle Définition du modèle.

            Vous pouvez supprimer des colonnes de la Définition du modèle, mais pas de la Définition des recettes ou de la Définition des unités.

          2. Cliquez sur l’en-tête numéroté pour sélectionner la ligne à supprimer.

          3. Dans le menu Édition, cliquez sur Supprimer. Un message vous demande de confirmer la suppression.

          4. Cliquez sur Oui. La ligne est supprimée du modèle.