Access Denied to AVEVA Work Tasks Temp Folder along with System IO Errors
- Last UpdatedJun 06, 2024
- 1 minute read
Issue
User receives an error while accessing Central Configuration or Enterprise Console and Logger Console logs System IO errors accessing specific file in AVEVA Work Tasks Temp folder (C:\Windows\Temp\AVEVAWorkTasksTemp).
Probable Cause
Access Control List (ACL) updated by Windows updates or policies.
Resolution
Provide access to AVEVA Work Tasks Temp Folder (C:\Windows\Temp\WorkTasksTemp):
-
Delete and recreate AVEVA Work Tasks Temp folder.
OR
-
Provide access to account ApplicationPoolIdentity.
OR
-
Provide access to group Everyone.
Note: This option is not recommended as it will leave your system open to security vulnerabilities.
References
For more information on:
-
Application Pool Identities, see https://docs.microsoft.com/en-us/iis/manage/configuring-security/application-pool-identities
-
Access Controls, see https://technet.microsoft.com/en-us/library/dd277411.aspx