Please ensure Javascript is enabled for purposes of website accessibility
Powered by Zoomin Software. For more details please contactZoomin

AVEVA™ Work Tasks

Error while reinstalling AVEVA Work Tasks Client

  • Last UpdatedDec 06, 2024
  • 1 minute read

Issue 1:

The AVEVA Work Tasks Server/Client configuration fails while using Farm Configuration Wizard, displaying an error message: "The given key was not present in the dictionary."

Cause:

This issue occurs if AVEVAWorkTasksSites is already present in IIS before configuring the farm. In this scenario, an entry for AVEVAWorkTasksSites is not created in the SKWebSite table during the configuration process.

Solution:

To resolve this issue, follow these steps:

  1. Open IIS Manager.

  2. Locate and delete the AVEVAWorkTasksSites site from IIS.

  3. Use the Farm Configuration Wizard to reconfigure the farm. Ensure that a new Farm Database is used during the configuration process.

Issue 2:

When clicking the Edit icon in Enterprise Console under Farm Configuration, the following error is displayed: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index

Cause:

This issue occurs if AVEVAWorkTasksSites is already present in IIS before configuring the farm. In this scenario, an entry for AVEVAWorkTasksSites is not created in the SKWebSite table during the configuration process.

Solution:

To resolve this issue, follow these steps:

  1. Open IIS Manager.

  2. Locate and delete the AVEVAWorkTasksSites site from IIS.

  3. Use the Farm Configuration Wizard to reconfigure the farm. Ensure that a new Farm Database is used during the configuration process.

    Related Links
    TitleResults for “How to create a CRG?”Also Available in