Troubleshoot
- Last UpdatedMar 20, 2025
- 2 minute read
Issue 1:
The following error message is displayed when Quickflow is not deployed properly:
Error while deploying Quickflow in one of the machines. For more information, refer the logger console and Troubleshooting section in Quickflow help document.
Possible Causes
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The certificate generated by System Management Server has been used for both Quickflow and AIM.
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The port number is used by other application.
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Connectivity to Message Broker must have failed.
Resolution
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Ensure the AIM certificate and the Quickflow certificate are not same.
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Ensure the port number is not 443 if AIM is installed on the same machine.
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Ensure Message Broker Connection is proper. Refer, Resolving Message Broker Connection below to resolve the connectivity failure.
Resolving Message Broker Connection
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Verify whether the AMQP plugin is enabled. Run the command in the Command Prompt:
C:\Program Files\RabbitMQ Server\rabbitmq_server-3.7.10\sbin>rabbitmq-plugins list

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If AMQP plugin is not enabled, run the command:
C:\Program Files\RabbitMQ Server\rabbitmq_server-3.7.10\sbin>rabbitmq-plugins enable rabbitmq_amqp1_0
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Ensure all the listeners are listed in the Configure RabbitMQ Listener Details page. To ensure all the listeners are listed, run the command:
C:\Program Files\RabbitMQ Server\rabbitmq_server-3.7.10\sbin>rabbitmqctl status
While executing the above commands displays any error like “node unreachable”, follow one of the steps:
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Restart the RabbitMQ windows service.
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Restart the machine where RabbitMQ is installed.
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If none of the above steps resolve the error, repair/reinstall RabbitMQ.
Issue 2:
Quickflow is either not functioning properly, finishing with errors, or taking long time to complete.
Possible Causes
This issue may occur if multiple versions of RabbitMQ are installed on the machine, causing conflicts during Quickflow operations.
Resolution
To resolve this issue, follow these steps:
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Navigate to the folder: C:\Users\<UserName>\AppData\Roaming
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Locate and delete the RabbitMQ folder.
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Restart the Quickflow process and verify if the issue is resolved.