Please ensure Javascript is enabled for purposes of website accessibility
Powered by Zoomin Software. For more details please contactZoomin

AVEVA Enterprise SCADA

Pivot and Transfer from a Perspective Root

  • Last UpdatedApr 24, 2025
  • 2 minute read

You can Pivot and Transfer a set of records in a perspective at one time by performing a Pivot and Transfer from the Perspective Root dialog box.

You can Pivot and Transfer one Perspective Root record at a time. You can also Pivot and Transfer one Perspective child record from each of the tables that are connected to the Perspective Root record.

Procedure

  1. Select View > Perspective.

  2. Open the Perspective Root dialog box (source) that contains the records you want to transfer.

    All the Perspective child dialog boxes appear as well.

    Embedded Image (65% Scaling) (LIVE)

  3. In the Perspective Root dialog box, select Tools > Pivot and Transfer.

    The System Selector dialog box appears.

  4. In the Select Target System field, select a valid target system from the list.

  5. Select Transfer.

    Note: If the Select Target System field is empty (or has an invalid target system), an error message will appear reminding you to select a target system. Select OK on the error message, and select a valid target system from the list.

    Either an Advanced Database Editor (ADE) login dialog box or the target Row Edit dialog box appears.

  6. If required, enter your User name and Password, and select OK in the ADE login dialog box.

  7. Different actions are required depending on whether or not the Root record exists in the target system. Do one of the following:

    • If the Root record exists in the target system, the target Perspective Root dialog box and all its child dialog boxes are opened. Select Table > Save Changes.

    • If the Root record does not exists in the target system, then the target Perspective Root dialog box is opened, but its child dialog boxes are not. Do the following:

      1. Select Table > Save Changes.

        The Perspective Root record is created in the target system, and all the Perspective child dialog boxes related to that Perspective appear.

      2. Select Table > Save Changes.

        The transfer of the records to the target system is complete.